گروه ای‌سی‌ام دانشگاه جهرم

يكشنبه, ۳ اسفند ۱۳۹۳، ۰۵:۵۱ ب.ظ

۱

Number Steps

يكشنبه, ۳ اسفند ۱۳۹۳، ۰۵:۵۱ ب.ظ

Starting from point (0,0) on a plane, we have written all non-negative integers 0,1,2, … as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued.

y

 

 

 

 

 

 

 

 

.

 

 

6

 

 

 

 

 

 

12

 

.

 

5

 

 

 

 

 

9

 

11

 

 

4

 

 

 

 

8

 

10

 

 

 

3

 

 

 

5

 

7

 

 

 

 

2

 

 

4

 

6

 

 

 

 

 

1

 

1

 

3

 

 

 

 

 

 

0

0

 

2

 

 

 

 

 

 

 

 

0

1

2

3

4

5

6

7

 

 

 

 

 

 

 

 

 

 

 

X


You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0…5000.

Input

The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.

Output

For each point in the input, write the number written at that point or write No Number if there is none.

Sample Input

3

4 2

6 6

3 4

Sample Output

6

12

No Number






موافقین ۰ مخالفین ۰ ۹۳/۱۲/۰۳
مجتبی شمس

نظرات  (۱)

#include<iostream>
using namespace std;

int main()
{
	int t,x,y;
	cin>>t;
	while(t>0)
	{
		cin>>x>>y;
		if(y==x || y+2==x)
		{
			if(y%2==0 && x%2==0)
				cout<<x+y<<endl;
			else
				cout<<(y+x)-1<<endl;
		}
		else
			cout<<"No Number\n";
		t--;
	}
	return 0;
}

ارسال نظر

کاربران بیان میتوانند بدون نیاز به تأیید، نظرات خود را ارسال کنند.
اگر قبلا در بیان ثبت نام کرده اید لطفا ابتدا وارد شوید، در غیر این صورت می توانید ثبت نام کنید.
شما میتوانید از این تگهای html استفاده کنید:
<b> یا <strong>، <em> یا <i>، <u>، <strike> یا <s>، <sup>، <sub>، <blockquote>، <code>، <pre>، <hr>، <br>، <p>، <a href="" title="">، <span style="">، <div align="">
تجدید کد امنیتی